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Chapter 1

Getting started

This chapter helps you install and run MuseScore for the first time. The
chapter will also show you how to create a new score.

Installation
MuseScore works on many different computer systems including, Windows,
Mac OS, and Linux.

Windows
You can get the Windows installer from the Download page of the MuseScore
website. Click on the link to start the download. Your Internet browser will
confirm that you want to download this file. Click "Save File".

When the download finishes double click on the file to start the installation.
Windows may open a security window and ask you to confirm before running
the software. Click "Run" to continue.

http://musescore.org/en/download
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The installer recommends that you close all other applications before
continuing. After you close the other applications click "Next" to continue.

The setup wizard displays the terms of the free software license which you
may review. Click "I Agree" to continue.

Next it confirms the location for installing MuseScore. If you are installing a
newer version of MuseScore but still want to keep the old version on your
computer then you should change the folder. Otherwise click "Next" to
continue.

Next it confirms the name for the MuseScore folder that appears in the
Windows Start menu list of programs. Click "Install" to continue.

Give the setup wizard a few minutes to install the necessary files and
configurations. When it is done click "Finish" to exit the installer. If you wish,
you may now delete the installer file you downloaded.

Start MuseScore
To start MuseScore choose Start → All Programs → MuseScore → MuseScore.

After several seconds MuseScore will open up to the demo score. Feel free to
experiment with the demo score and get the feel of the program. Next you
may want to create your own score.
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Advanced users: Silent or unattended install
You can install MuseScore silently with the following command
MuseScore-X.Y.exe /S /D=C:\Program Files\MuseScore

You can uninstall with
cd C:\Program Files\MuseScore

Uninstall.exe /S

Mac OS X

Install
You will find the Mac dmg file on the Download page of the MuseScore
website. Click on the link to start the download. When download is finished,
the dmg file is automatically mounted on your desktop as "MuseScore-X.Y"
and the installer appears.

http://musescore.org/en/download
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Drag the MuseScore icon and drop it to the Applications folder icon. If you
are not logged in as an administrator, Mac OS X will ask for a password:
click "Authenticate" and enter your password to let Mac OS X copy
MuseScore into your Application folder.
You can now launch MuseScore from Applications or SpotLight.

Uninstall
Just delete MuseScore from Applications folder.

Linux
Please see the Download page for instructions pertaining to MuseScore on
Linux. Packages are provided for Debian, Ubuntu, Fedora and PCLinuxOS.
Other distributions will require you to build the application from source. For
instructions specific to Fedora see below.

Fedora
Import the GPG key:

su

rpm --import http://prereleases.musescore.org/linux/Fedora/RPM-GPG-KEY-Seve

http://musescore.org/en/download
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2. Go to the download page of the MuseScore website. Click on the link for
the stable Fedora download and choose the correct rpm package for your
architecture

3. Depending on your architecture, use one of the two sets of commands
to install MuseScore

if for arch i386

su

yum localinstall musescore-X.Y-1.fc10.i386.rpm

or if for arch x86_64

su

yum localinstall musescore-X.Y-1.fc10.x86_64.rpm

If you have difficulty with sound, see Fedora 11 and sound.

Create New Score
From the main menu choose File → New.... This opens the new score wizard.

Title, composer and other information

Enter the title, composer, or any other information as shown above. Notice
the two options at the bottom:

• Create new score from template

• Create new score from scratch

The first option offers a list of ready-made scores in the next screen. The 
second option gives you the full choice of instruments in the next screen.

http://musescore.org/en/download
http://www.musescore.org/en/node/3848#comment-9634
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Templates are discussed in more detail below, but for now, choose "Create
new score from scratch."

Click "Next" to continue.

Instruments and voice parts

The instrument window is divided into two columns. The first column lists
instruments or voice parts to choose from. The second column is initially
empty, but will soon contain a list of the instruments for your new score.

The instrument list in the first column is categorized into instrument
families. Double click a category to show the full list of instruments in each
family. Select an instrument and click "Add". The instrument you selected
now appears in the second column. You can add more instruments or voice
parts, if needed.

The order of the instruments in the second column determines the order they
appear in the score. To change the order, click on an instrument name and
use the "Up" or "Down" buttons to move it higher or lower. When you are
done, click "Next".

Key signature
The wizard asks for a key signature. Select the key signature you need and
click "Next" to continue.

Time signature, pickup, and number of measures



8

Set the time signature to the numbers you want. If your piece begins with a
pickup, then mark the "Pickup measure" checkbox and adjust pickup time
signature to indicate the actual duration of the first measure.

If you know approximately how many measures you need, you can specify
that here. Otherwise, you can add, or delete measures later.

Click "Finish" to create your new score.

Adjustments to score after creation
You can change any settings specified during the new score wizard, even
after you start working on the score.

• To add or delete measures or create a pickup see Measure operations

• To change any text see Text editing. To add a missing Title (or other text
item) use the menu Create → Text → Title (or other text item)

• To add, delete, or change the order of instruments use the menu Create →
Instruments....

See also: Key signature, time signature, clef.

Templates
The first screen of the new score wizard has an option to "Create new score
from template" (see Title and other text above for details). To create a score
using this method, select the template option and click "Next" to continue.

The next screen shows a list of templates. Select a template and click "Next".
Continue and finish the new score wizard as usual.

The template files are normal MuseScore files stored in the template folder. 
You can create your own templates by saving MuseScore files to the 
template folder. On Windows, the template folder is usually located at 
C:\Program Files\MuseScore\templates. On Linux, look under
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/usr/share/mscore-xxx if you installed from the package manager. If you
compiled mscore on Linux, then look under /usr/local/share/mscore-xxx. On
Mac, look under /Applications/MuseScore.app/Contents/Resources/templates

External links
• Video tutorial: Score Setup

http://www.youtube.com/watch?v=0mh6m2mbvhs
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Chapter 2

Basics

The "Getting started" chapter above guides you through the Installation and
process for creating a new score. The "Basics" chapter gives an overview of
MuseScore and describes the general methods for interacting with the score.

Note entry
Adding notes and rests to a staff requires four basic steps:

1. Select your starting position for note entry

2. Select Note entry mode

3. Select the duration of the note (or rest) you want to enter

4. Enter the pitch (or rest) using keyboard shortcut, mouse or a MIDI
keyboard

To add notes that overlap in time, but start or end at different times,
see Voices. For chords, continue reading here.

Step 1: Starting position
First, select a note, or rest on the score as your starting position for note
entry. Note entry in MuseScore replaces the existing notes or rests in a
measure with your new notes (i.e. overwrites rather than inserts). However,
you can insert new measures at any point (see measure operations, "Insert"),
or use copy and paste to move a passage of notes.

Step 2: Note entry mode
The "N" button on the Note Entry toolbar indicates whether you are in note
entry mode or not. Besides clicking the button, you can also use the
following keyboard shortcuts:

• N: Enter Note entry mode
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• N or Escape: Leave Note entry mode

Step 3: Duration of the note
After entering Note entry mode, select the duration of the note you need
from the Note Entry toolbar, or use the corresponding keyboard shortcut.

The keyboard shortcuts for selecting the note duration are:

• 1: 64th note (hemidemisemiquaver)

• 2: 32nd note (demisemiquaver)

• 3: 16th note (semiquaver)

• 4: Eighth note (quaver)

• 5: Quarter note (crotchet)

• 6: Half note (minim)

• 7: Whole note (semibreve)

• 8: Double whole note (breve)

• 9: Longa

• .: A period (dot) changes the selected duration into a dotted note

Step 4: Enter pitch
For all instruments (except unpitched percussion), you can add note pitches
using the mouse by clicking directly on the staff. (For instructions specific to
percussion see Drum notation). However, you may find it quicker to use a
MIDI keyboard (see below), or your alphabetical keyboard. The following
examples use a standard computer keyboard.

Enter pitches by typing the corresponding letter on your keyboard:
C D E F G A B C

0 (Zero) creates a rest: for example C D 0 E. Notice that the duration you
select for the notes (quarter/crotchet notes in this example) also determines
the duration of the rest (quarter/crotchet rest).

During note entry, MuseScore automatically advances in the score. If you
want to add a chord note to your previous entry, hold Shift and enter a note
name: C D Shift+F Shift+A E F
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To create chords with notes of different durations, see voices.

If you want to create a dotted note, press .. For example 5 . C 4 D E F G A

When you type a note on the keyboard, MuseScore chooses the octave
closest to the previous note entered. To shift your note up or down by an
octave, use the following keyboard shortcuts:

• Ctrl+↑ (Mac: ⌘+↑): Increase the pitch of a note by one octave.

• Ctrl+↓ (Mac: ⌘+↓): Decrease the pitch of a note by one octave.

Other useful editing keyboard shortcuts available in Note Entry Mode:

• ↑ (Up): Increase the pitch of a note by a semitone (uses sharps).

• ↓ (Down): Decrease the pitch of a note by a semitone (uses flats).

• R: Duplicate the last entered note

• Q: Halve the duration of the last entered note

• W: Double the duration of the last entered note

• Backspace: Undo last entered note

• X: Flip direction of note stem

• Shift+X: Move note head to opposite side of stem

MIDI keyboard
You can also insert pitches using a MIDI keyboard.

1. Connect your MIDI keyboard to the computer and switch your keyboard
on

2. Start MuseScore

3. Create a new score

4. Click to select the rest in measure 1 to indicate where you want note
entry to begin

5. Press N to begin note entry mode

6. Select a note duration such as 5 for quarter notes (crotchets), as
described above

7. Press a note on your MIDI keyboard, and notice that the pitch is added
to your score

Note: The MIDI keyboard enters one note or chord at a time. This mode of 
note entry (often called "step-time entry") is fast and reliable. Some notation 
software try to interpret "real-time entry", where the musician plays a 
passage and the software tries to create the notation. However, the results 
are frequently unreliable, even when played by a skilled musician using
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expensive software. MuseScore's focus is on more reliable forms of note
entry.

If you have multiple MIDI devices connected to your computer, you may need
to tell MuseScore which one is the MIDI keyboard. Go to Edit → Preferences...
(Mac: MuseScore → Preferences...). In the preferences dialog, click on the I/O
tab and select your device under the section labeled "Choose PortMidi input
device".

Coloring of notes out of an instrument's range
Notes within the playable range of an instrument or voice part appear
appear black, whilst notes extending beyond the normal range of an
instrument, are marked red. For some instruments, the range depends on
the skills of the musician (such as string, wind, or voice). For these
instruments, notes outside the range of an early amateur appear dark yellow,
and notes outside the typical range of a professional appear red.

The colors are informational and appear on the computer screen but do not
appear on printed copies of your scores. To disable note colors, choose Edit →
Preferences... (Mac: MuseScore → Preferences...), click on the Note Entry tab, and
unmark "Color notes outside of usable pitch range".

See also
• Drum notation

External links
• Video tutorial: Note entry basics

Copy and paste
Copy and paste is useful tool for repetitious music, or for shifting a section of
music by a beat or two.

Copy
1. Click on the first note of your selection.

2. Shift+click on the last note of your selection. A blue rectangle highlights
the region you selected.

3. From the menu choose Edit → Copy

Paste
1. Click on the note or measure that you want your pasted selection to

begin.

2. From the menu, choose Edit → Paste

http://www.youtube.com/watch?v=ugzgezapbge
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